当前位置:首页 > 网络 > 正文内容

华为路由调试——初级调试

3年前 (2018-08-08)网络32

一、初始化

华为设备初始化启动会有检测设备内存操作系统等的提示,初始化界面的最后一句Do you want to stop Auto-config?[y/n]?是否进行自动配置,其实就是进行"傻瓜"化配置

二、进入系统视图

启动设备是进入了用户视图---------查看运行状态或查看其它参数

system-view 进入系统视图-------配置设备的系统参数等

系统视图下敲入接口如:interface GigabitEthernet 0/0/0--------进入接口视图配置接口参数

接口上启动协议进入协议视图,当然有的设备在系统视图是可以直接进入协议视图不需要进入接

口后再进入协议视图的,而协议视图的作用就是配置路由协议,不同的视图命令进入不同视图模

式。

sysname R1改设备名为R1

clock timezone BJ add 08:00:00设置所在时区为北京正八区

clock datetime 10:00:29 2017-04-01设置时间为10:00:29 2017年4月1日

三、标题消息

标题消息是连接或登录设备时设备对用户的一个提示或者说是免责声明,起提是免责和警告作

用,国外用的比较多,国内不规范,最好去试着使用

header login information “welcome to huawei certification!”

header shell information“Please don't reboot the device!”

四、配置等级

华为的设备权限等级划分为(0-15)级,0是仅有访问级,1级包含(0和1)监控级,2级配置

级,3级以上默认有save权限

五、用户界面

什么是用户界面,可以理解为远程登录、虚拟连接所需进入的门口

当远程登录(用线通过console口连接也可以理解为远程的一种)用console口连接设备时使用的

用户界面类型是console(编号0),telnet连接用的是用户界面类型是VTY(编号0-4)

sys

user-interface vty 0 40-4共5个线路进行配置

华为的VTY接口最大范围是0-14,即共有15个人可以进入这个接口

六、配置用户界面

例如:设置console口的细节参数,所以在设备启动的前提下需要进入系统视图(sys),然后进入console口,敲入命令如下:

sys

user-interface console 0这样进入了console口

idle-timeout 1 30设置console口超时时间为1分30秒

scree-length 20/*设置指定终端屏幕的临时显示行数为20行,切记此命令值不能设置为0,因为设置为0时候就不会显示配置内容了*/

history-command max-size设置历史命令的缓冲区的大小

七、配置登录权限

方法1(此方法只有密码无用户名):

sys

user-interface vty 0

user privilege level 2配置vty0这个用户连接上来的权限为2

set authentication password cipher huawei/*配置这个接口的认证密码为huawei且为密文其中cipher就是让密码为密文*/

方法2(配置认证模式有用户名和密码):

sys

user-interface vty 0 4配置5个线程

authentication-mode aaa开启aaa认证模式

quit

aaa

local-user huawei password cipher huawei@123配置用户名huawei密码huawei@123

local-user huawei privilege level 3配置huawei这个用户连接上来的权限为3

local-user huawei service-type telnet开启telnet

八、配置接口的ip地址:

sys

interface gigabitethernet 0/0/0

ip address 10.0.12.1 255.255.255.0/* 配置0/0/0口ip地址为10.0.12.1子网掩码为

24,这个子网页码可写为24,是一样的*/

interface loopback 0

ip address 1.1.1.1 32回环可用来自测,例如测试远程登录是否启用、以及密码是否启用

注意:telnet在设备测试时候必须在用户视图下进行

九、对接口的描述

在接口下写入description to Link_To_LianTongJiFang是对接口的描述,这样子可以在以后的网络管理中更快速的知道某个口是通向哪里

undo negotiation auto关闭自动协商

十、静态路由

ip route-static目标地址子网掩码下一跳

dis ip int br查看接口的启用ip地址

dis ip routing-table查看路由表信息

ping -a测试路由的ip 目标路由的ip

上图要实现的目的是pc1能ping通pc2,中间三个路由也都能相互ping通,通过静态路由实现以上跨网段通信

其中AR1需要写入的静态路由是:

ip route-static 10.0.1.0 255.255.255.0 10.0.0.2

ip route-static 192.168.2.0 255.255.255.0 10.0.1.2

AR2写入的静态路由是:

ip route-static 192.168.1.0 255.255.255.0 10.0.0.1

ip route-static 192.168.2.0 255.255.255.0 10.0.1.2

AR3写入的静态路由是:

ip route-static 10.0.0.0 255.255.255.0 10.0.1.1

ip route-static 192.168.1.0 255.255.255.0 10.0.0.1

其实从以​​​​上的例子可以看出来,要实现全网通信那么指静态路由就需要一级一级往上指,因为网络的通信也是有访问就有返回信息的,所以,回程路由也是需要一级一级指回来,这样才形成了完整的通信。

引用:[1]百度经验;[2]CSDN

扫描二维码推送至手机访问。

版权声明:本文由豆子林克发布,如需转载请注明出处。

除特别申明外,本站原创内容版权遵循 CC-BY-NC-SA 协议规定 

本文链接:https://www.douzi.link/post/347.html

分享给朋友:
返回列表

上一篇:思科基础命令大全

没有最新的文章了...

相关文章

移除BT宝塔面板的nginx默认404页面

移除BT宝塔面板的nginx默认404页面

以前用的是Apache环境404页面一直都没啥问题,自从迁移新的服务器使用Nginx后404总是指向Nginx的默认404页面,在宝塔论坛找了半天也没有找到答案。有次碰巧在felicoz找到了答案。修改的方式很简单。在宝塔面板里面,到网站...

思科基础命令大全

路由器的基本配置 1.从用户模式进入特权模式 R1>enable 2.从特权模式进入全局配置模式 R1#configure terminal 3.设置主机名 R1(config)#hostname R1 4. 退出到特权...

发表评论

访客

看不清,换一张

◎欢迎参与讨论,请在这里发表您的看法和观点。